Monday, May 16, 2011

Storage related AIX Commands

See the current OS levels
uname -a
oslevel -r
oslevel -q
oslevel -g

See adapters, drivers, and microcode.See the bottom of this section for AIX part number mappings
lsdev -Cc adapter -spci | grep fcs   For each of the FCS instances

Micorcode
lsmcode -cd fcs0

Firmware
lscfg -vl fcs0 | grep Z9

Driver
lsdev -C -Ftype,name | grep -i fcs

Software
lslpp -l | grep -i hba
lslpp -l | grep “FC Software”
lslpp -L EMC.Symm*   Should get two outputs – aix and fcp
lslpp -L devices.pci.df1000f7.com
lslpp -L devices.pci.df1000f*

Disk type/info
lsattr -El hdisk
lsattr -El vpath

List Powerpath info

Software
lslpp -l | grep -i powerpath

Devices
lsdev -C -t power

WWN
Loop for each adapter
lscfg -vl fcs0 | grep Z8

IBM Part numbers
To determine the part numbers for the HBAs
lscfg -vpl fcs0 | grep “Part Number”

To corrolate the Part Number from above to a “Feature Code
that EMC uses in their documentation OR to a HBA vendor model.

Emulex LP10000  FC 5716
80P4543 (FRU 80P4544)
80P4544
Emulex LP9002   FC 6228
00P2995 (FRU 00P2996)
00P2996
00P4494 (FRU 00P4495)
00P4495
03N2452 (FRU 09P0102)
09P0102
09P5079 (FRU 09P5080)
09P5080
80P4381 ???
80P4384
Emulex LP9802   FC 6239
00P4295
00P4297
Emulex LP7000   FC 6227
00P1882
03N4167
09P1162
09P1173
09P4038
24L0023

INITIAL load software, drivers and firmware
NOTE: You may need to modify lines for the APPROPRIATE version
mount nimserver:/depot/Software/UNIX /mnt

Drivers
See if they are already loaded
lslpp -L devices.pci.df1000f*

If not, then
cd /mnt/aix/aix52_apar_IY56722
installp -a -Q -d . devices.pci.df1000fa.rte
smit install_software
use dot (.) for directory
select the following:
devices.pci.df1000fa
devices.pci.df1000f7

Multipath software
AIX
lsvpcfg
lspv

AIX SDD
datapath query version
datapath query adapter
datapath query device
datapath query essmap
datapath query wwpn
datapath query portmap
datapath query adaptstats <n>
datapath query devstats <n>

EMC Symmetrix software

cd /mnt/EMC/Drivers/AIX
installp -qa -d ./EMC.AIX.5.2.0.0  EMC.Symmetrix.aix.rte EMC.Symmetrix.fcp.rte

EMC ECC package
cd /mnt/EMC/ECC/Control_Center_5.2
./install_master.sh ‘pwd‘
/opt/ecc
ECC-servername
default
default
Y
/opt/ecc/exec/start_master.csh

echo “ecc:2:once:/opt/ecc/exec/start_master.csh > /dev/console 2>&1 Start ECCagent” >> /etc/inittab

EMC PowerPath

Must have a valid PowerPath license for this host
cd /mnt/EMC/PowerPath/PowerPath4.4/aix
installp -qa -d ./EMCpower_install EMCpower
/usr/sbin/emcpreg -install
/usr/sbin/powermt check_registration
View SDD
lsvpcfg
datapath query adapter
datapath query device
5.X and greater
iostat -m

Initialize HBAs in ODM
diag
Advanced Diag Routines
System Verification
(select each fcsX => F7)
loopback plug? no
F10

Configure disks
cfgmgr -vl fcs0
cfgmgr -vl fcs1

EMC Symmetrix software
cfgmgr -v
/usr/lpp/EMC/Symmetrix/bin/emc_cfgmgr
/usr/sbin/powermt config
/usr/sbin/powermt save

SDD
config HBA into SDD
/usr/sbin/allpaths

config Paths via HBA
cfgmgr -l dpo
**or**
/usr/lib/methods/cfallvpath -2

lsdev -Cc disk | grep -i emc
lspv

if this is the DR node, it needs to see failover disk’s serial numbers
so in can import the volumegroup
for DISK in $(lspv | grep hdiskpower | awk ‘{print $1}’)
do
echo $DISK
chdev -l $DISK -a pv=yes
done

No comments:

Post a Comment